首页 > PHP技术 > php高级 > Git的版本冲突怎么解决?
2020
09-30

Git的版本冲突怎么解决?

attachments-2020-09-5d77f1mZ5f72f87abe091.png


attachments-2020-09-jNiGS1AE5f72e428504bb.png

 产生原因:因为你提交的时候你本地的代码不是最新版本,所以git不知道以那个版本为标准,为了防止代码覆盖,git不允许你的提交

 解决

从错误信息中可以看出,第一步,让你git pull

attachments-2020-09-64daWoYf5f72e41ec4887.png

vim编辑器打开冲突文件(这里我是用习惯了vim)

attachments-2020-09-3fuQbFzf5f72e43e5d14c.png

 把你想保留的留下,然后保存退出

然后提交步骤再来一次即可

git add. git commit -m "冲突解决" git push


扫码芷若 获取免费视频学习资料

编程学习

查 看2019高级编程视频教程免费获取